Network requirement
This project describes to design the Primary School network design with guest network. Before real time implementation, we make the network simulation for these network. After analyzing the network traffic, we will implement this network using network devices such as cisco, netgear and etc.
Project Requirements
We need to design the small network in school environment for School and Guest User. School user can communicate with FTP Server, but not Guest User. First, we need to design the network address using subnetting concepts. After that we need to configure the IP address to specified devices and test the communication those devices.
Network Design using User-Centric Concepts
School campus is the center of the network communication. All the user communicate through School Router Device. Guest and School user can communicate through School Router. Another one, School User can upload/download the files from/to FTP Server via School Router
IP Address Table including netmask
Subnetting
We have chosen the network address of 200.200.200.0 (/24). In subnetting, we should take the highest IP required network at first. In School User network, it required 50 IP addresses. In Guest User network, it required 10 IP addresses.
Network Name |
Network Address |
Subnet Address |
Start IP Address |
Last IP Address |
Subnet Mask |
Student |
200.200.200.0 |
255.255.255.192 (/26) |
200.200.200.1 |
200.200.200.62 |
200.200.200.63 |
Guest |
200.200.200.64 |
255.255.255.240 (/28) |
200.200.200.65 |
200.200.200.78 |
200.200.200.79 |
School-Server |
200.200.200.80 |
255.255.255.252 (/30) |
200.200.200.81 |
200.200.200.82 |
200.200.200.83 |
FTP Server |
172.16.0.0 |
255.255.255.0 (/24) |
172.16.0.1 |
172.16.0.254 |
172.16.255 |
In Student network, we have chosen the subnet address of 255.255.255.192. It allows 64 address. But the number of usable IP address is 62 (First IP used for Network address and Last IP used for broadcast Address in every network)
IP Allotment
Device Name |
Interface Name |
IP Address |
Subnet Mask |
Default Gateway |
School |
Fa 0/0 |
200.200.200.1 |
255.255.255.19 |
– |
Fa 0/1 |
200.200.200.65 |
255.255.255.240 |
– |
|
S 0/0 |
200.200.200.81 |
255.255.255.252 |
– |
|
School User1 |
Eth 0 |
DHCP Addressing with the network of 200.200.200.0 |
||
School User2 |
Eth 0 |
|||
Guest User1 |
Eth 0 |
DHCP Addressing with the network of 200.200.200.64 |
||
Guest User2 |
Eth 0 |
|||
Server |
S 0/0 |
200.200.200.82 |
255.255.255.252 |
– |
Fa 0/0 |
172.16.0.1 |
255.255.255.0 |
– |
|
FTP Server |
Eth 0 |
172.16.0.2 |
255.255.255.0 |
172.16.0.1 |
Network Topology DiagramSwitch Configuration
We configure the basic security configuration in SchoolLAN and GuestLAN switch devices. No need to configure any IP address in these devices
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname StudentLAN
StudentLAN(config)#line console 0
StudentLAN(config-line)#password cisco
StudentLAN(config-line)#login
StudentLAN(config-line)#exit
StudentLAN(config)#line vty 0 4
StudentLAN(config-line)#password cisco
StudentLAN(config-line)#login
StudentLAN(config-line)#exit
StudentLAN(config)#enable secret class Router Configuration
In School router, we have configured Fast Ethernet and Serial Interface IP address
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname School
School(config)#int fa0/0
School(config-if)#ip address 200.200.200.1 255.255.255.192
School(config-if)#no shut
School(config-if)#exit
School(config)#int fa0/1
School(config-if)#ip address 200.200.200.65 255.255.255.240
School(config-if)#no shut
School(config-if)#exit
School(config)#interface s0/0
School(config-if)#ip address 200.200.200.81 255.255.255.252
School(config-if)#clock rate 64000
School(config-if)#no shut
School(config-if)#exit
School(config)#line console 0
School(config-line)#password cisco
School(config-line)#login
School(config-line)#exit
School(config)#line vty 0 4
School(config-line)#password cisco
School(config-line)#login
School(config-line)#exit
School(config)#enable secret class
School(config)#exitIn Server Router, we have configured FTP Server default gateway address and serial address to communicate with school router
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Server
Server(config)#interface ser0/0
Server(config-if)#ip address 200.200.200.82 255.255.255.252
Server(config-if)#no shut
Server(config-if)#exit
Server(config)#interface fa0/0
Server(config-if)#ip address 172.16.0.1 255.255.255.0
Server(config-if)#no shut
Server(config)#line console 0
Server(config-line)#password cisco
Server(config-line)#login
Server(config-line)#exit
Server(config)#line vty 0 4
Server(config-line)#password cisco
Server(config-line)#login
Server(config-line)#exit
Server(config)#enable secret classDHCP Configuration
We have created the DHCP Pool for School and Guest Users. We have removed the router IP address from the DHCP pool
School# conf t
Enter configuration commands, one per line. End with CNTL/Z.
School(config)#ip dhcp pool SchoolDHCPPool
School(dhcp-config)#network 200.200.200.0 255.255.255.192
School(dhcp-config)#default-router 200.200.200.1
School(dhcp-config)#exit
School(config)#ip dhcp excluded-address 200.200.200.1
School(config)#
School(config)#ip dhcp pool GuestDHCPPool
School(dhcp-config)#network 200.200.200.64 255.255.255.240
School(dhcp-config)#default-router 200.200.200.65
School(dhcp-config)#exit
School(config)#ip dhcp excluded-address 200.200.200.65Access Point, Server Configuration
We have restricted the FTP Server access for Guest User network. School User IP can communicate with FTP Server and Guest User. But Guest user cannot communicated with FTP Server using ACL configuration
We have configured the ACL command in Server Router Serial Interface (Inward)
Server(config)#ip access-list extended 101
Server(config-ext-nacl)#deny ip 200.200.200.64 0.0.0.15 any
Server(config-ext-nacl)#permit ip any any
Server(config-ext-nacl)#exit
Server(config)#inter s0/0
Server(config-if)#ip access-group 101 in
Server(config-if)#exitStatic Routing
In Server Router, we have configured the remote network address with exit IP adderss
Server(config)#ip route 200.200.200.0 255.255.255.192 200.200.200.81
Server(config)#ip route 200.200.200.64 255.255.255.240 200.200.200.81
Similarly, we have configured the static ip routing in School router
School(config)#ip route 172.16.0.0 255.255.255.0 200.200.200.82
Setting FTP Server IP in command prompt
C:>ipconfig /ip 172.16.0.2 255.255.255.0
C:>ipconfig /dg 172.16.0.1Testing
DHCP IP Allotment in School User1Conclusion
We have implemented the static route for communicate between School user and FTP Server. Static route is not recommended for large scale network for security reason. In future, we may implement the dynamic routing such as OSPF, BGP and etc.
References
T. Support, D. Access, D. (DDR) and T. TechNotes, “Specify a Next Hop IP Address for Static Routes”, Cisco, 2018. [Online].
P. Support and E. Products, “Cisco IOS Configuration Fundamentals Command Reference, Release 12.2 – Basic Command-Line Interface Commands [Cisco IOS Software Release 12.2]”, Cisco, 2018.