Equipment and protocols for the functional elements
The report is prepared for company ABC for the development of the wireless call center network design. The network is designed following the requirement and improvement of the security of the voice and the data communications. The initial plan of the network is followed for the development of the network and enabling communication between the warehouse and the external customer. The network solution is created in cisco packet tracer and the devices are configured for testing the functionality of the network. The commands used for configuration of the IP phone and the router are attached in the document such that network administrator can find it easy to configure the hardware device installed in the company’s site. The errors in the configuration are tested multiple times and the installation location of the routers and the access points are verified for increasing the security of the network. The network diagram is labelled with the IP address used for configuring the interface and a justification of the design is given in the document.
Network Diagram
The network is designed based on the block diagram and for the external and the internal interface two routers are deployed. The router 1 is used to connect with the wireless warehouse and the router 2 is connected with a switch of the office network. Four IP phones and PC are used for the demonstration of the network architecture of the office. The router is configured with two VLANs one for the voice and the second for the data such that there is no collision between the voice and the data channel. The increase in traffic in the voice network can cause lag and delay in the call. The IP phones are setup and four digit number is assigned to them for connecting with the network. The IP phones are assigned number and the buttons are configured for enabling communication between the departments. The switch installed in the network are configured with encapsulation and the unused ports are blocked such that it cannot be used by any unauthorized device for communicating in the network. The router is configured with DHCP with the range of IP address for the different VLANS and the device connected in the network and automatically assigned with the IP address for enabling the communication.
Routing protocol is required for connecting the interfaces of the router 1 and router 2 and enabling the devices connected at the end of the interface to communicate with the device installed at the other interface of the second router. The routers are configured with EIGRP because it consumes less resource and reduces the load on the network. If there is a change in the topology of the network it can be revised using the new next hop address (Loo, Mauri and Ortiz 2016). Different vlans are created for the data and the voice network and the switch is configured with the encapsulation and switch port mode access for allowing the device to use the VLAN for communication (Lo Mills 2016). The default VLAN is used by the trunk port unless the VLAN is not defined and thus it is important to allow the access of the VLAN to the range of the switch port such that the data is communicated using the VLAN created for communication of the voice and the data.
Routing protocol and network connectivity
A wireless router is used and connected with the switch for connecting the wireless devices in the network. A proper network cabling plan is followed for connecting the routers and the switches in the network. The IP address used for configuring the devices are used for labeling the devices in the network diagram. The use of the trunk protocol helps in optimizing the performance of the access ports and it decreases the time for packet forwarding (Kizza 2017). The packet are received on the port with the VLAN value added on the header for forwarding it to the destination address. A point to point link is established between the devices connected in the network for allowing the different vlans to communicate with each other. The IEEE 802.1 Q encapsulation is also used for the insertion of the tag about the VLAN and identify the frame and the packet (Yan and Yu 2015). The encapsulation of the trunk also helps in transmission of the data packets in the end to end traffic through the network utilizing the same VLAN.
During the configuration of the port using the access mode the VLAN that would be used for carrying the traffic to that interface needs to be specified. If the VLAN is not defined in the access mode the default VLAN i.e. VLAN 1 is used for carrying the data traffic (Rautaray and Agrawal 2015). A new VLAN can be created in the switch and allowed its access unless if the access port receives the data packet with 802.1Q tag embedded in the header the without learning the VLAN information the packet is dropped.
For providing the evidence of the communication between the devices used for configuration of the network the following screenshot is attached. For testing the VOIP connection a call is placed from the IP phone with the assigned phone number and if the call is successfully established then the VOIP connection is also tested.
Configuration
Router 1 Configuration
Router(config-if)#
Router(config)#int s0/2/0
Router(config-if)#ip add 200.1.1.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/2/0, changed state to up
Router(config-if)#exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0, changed state to up
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 200.1.1.1 (Serial0/2/0) is up: new adjacency
Router(config)#router eigrp 1
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#network 200.1.1.0
Router(config-router)#network 99.99.99.99
Router(config-router)#network 10.1.1.0
Router(config-router)#network 10.1.2.0
Router(config-router)#exit
Router(config)#int s0/2/0
Router(config-if)#ip add 200.1.1.2 255.255.255.0
Router(config-if)#no shut
Router(config)#int s0/2/1
Router(config-if)#ip add 99.99.99.99 255.255.255.0
Router(config-if)#clock rate 64000
Wired and Wireless network configuration
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/2/1, changed state to up
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/1, changed state to up
Router(config-if)#
Router>
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int f0/0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#int f0/0.30
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.30, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.30, changed state to up
Router(config-subif)#encapsulation dot1Q 30
Router(config-subif)#ip add 192.168.1.1 255.255.255.0
Router(config-subif)#exit
Router(config)#int f0/0.40
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.40, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.40, changed state to up
Router(config-subif)#encapsulation dot1Q 40
Router(config-subif)#ip add 192.168.2.1 255.255.255.0
Router(config-subif)#exit
Router(config)#
Router(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.10
Router(config)#ip dhcp excluded-address 192.168.2.1 192.168.2.10
Router(config)#ip dhcp pool voice
Router(dhcp-config)#network 192.168.1.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.1.1
Router(dhcp-config)#option 150 ip 192.168.1.1
Router(dhcp-config)#exit
Router(config)#ip dhcp pool data
Router(dhcp-config)#network 192.168.2.1 255.255.255.0
Router(dhcp-config)#default-router 192.168.2.1
Router(dhcp-config)#option 150 ip 192.168.2.1
Router(dhcp-config)#exit
Router(config)#telephony-service
Router(config-telephony)#max-dn 10
Router(config-telephony)#max-ephone 10
Router(config-telephony)#ip source-address 192.168.1.1 port 2000
Router(config-telephony)#exit
Router(config)#ephone-dn 1
Router(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 1.1, changed state to up
Router(config-ephone-dn)#number 2001
Router(config-ephone-dn)#exit
Router(config)#ephone-dn 2
Router(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 2.1, changed state to up
Router(config-ephone-dn)#number 2002
Router(config-ephone-dn)#exit
Router(config)#ephone-dn 3
Router(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 3.1, changed state to up
Router(config-ephone-dn)#number 2003
Router(config-ephone-dn)#exit
Router(config)#ephone-dn 4
Router(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 4.1, changed state to up
Router(config-ephone-dn)#number 2004
Router(config-ephone-dn)#exit
Router(config)#
Router(config)#ephone 1
Router(config-ephone)#button 1:1
Router(config-ephone)#
%IPPHONE-6-REGISTER: ephone-1 IP:192.168.1.11 Socket:2 DeviceType:Phone has registered.
Router(config-ephone)#ephone 2
Router(config-ephone)#button 1:2
Router(config-ephone)#e
%IPPHONE-6-REGISTER: ephone-2 IP:192.168.1.13 Socket:2 DeviceType:Phone has registered.
Router(config-ephone)#exit
Router(config)#ephone 3
Router(config-ephone)#button 1:3
Router(config-ephone)#
%IPPHONE-6-REGISTER: ephone-3 IP:192.168.1.12 Socket:2 DeviceType:Phone has registered.
Router(config-ephone)#exit
Router(config)#ephone 4
Router(config-ephone)#button 1:4
Router(config-ephone)#exit
Router(config)#
%IPPHONE-6-REGISTER: ephone-4 IP:192.168.1.14 Socket:2 DeviceType:Phone has registered.
Router(config)#
Switch 1 Configuration
Switch>
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int f0/5
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#int range f0/1-4
Switch(config-if-range)#exit
Switch(config)#vlan 30
Switch(config-vlan)#name voice
Switch(config-vlan)#vlan 40
Switch(config-vlan)#name data
Switch(config-vlan)#exit
Switch(config)#int range f0/1-4
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 40
Switch(config-if-range)#switchport voice vlan 30
Switch(config-if-range)#exit
Switch(config)#
Router 2 Configuration
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int f0/0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#int f0/0.50
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.50, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.50, changed state to up
Router(config-subif)#
Router(config-subif)#encapsulation dot1Q 50
Router(config-subif)#ip add 10.1.1.1 255.255.255.0
Router(config-subif)#exit
Router(config)#int f0/0.60
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.60, changed state to up
Evidence of successful communication
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.60, changed state to up
Router(config-subif)#encapsulation dot1Q 60
Router(config-subif)#ip add 10.1.2.1 255.255.255.0
Router(config-subif)#
Router(config-subif)#
Router(config-subif)#exit
Router(config)#ip dhcp excluded-address 10.10.1.1 10.1.1.10
Router(config)#ip dhcp excluded-address 10.10.2.1 10.1.2.10
Router(config)#ip dhcp pool voice
Router(dhcp-config)#
Router(dhcp-config)#network 10.1.1.0 255.255.255.0
Router(dhcp-config)#default-router 10.1.1.1
Router(dhcp-config)#option 150 ip 10.1.1.1
Router(dhcp-config)#ip dhcp pool data
Router(dhcp-config)#network 10.1.2.0 255.255.255.0
Router(dhcp-config)#default-router 10.1.2.1
Router(dhcp-config)#option 150 ip 10.1.2.1
Router(dhcp-config)#exit
Router(config)#
Router(config)#telephony-service
Router(config-telephony)#max-dn 10
Router(config-telephony)#max-ephone 10
Router(config-telephony)#ip source-address 10.1.1.1 port 2000
Router(config-telephony)#exit
Router(config)#ephone-dn 1
Router(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 1.1, changed state to up
Router(config-ephone-dn)#number 3001
Router(config-ephone-dn)#exit
Router(config)#ephone-dn 2
Router(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 2.1, changed state to up
Router(config-ephone-dn)#number 3002
Router(config-ephone-dn)#exit
Router(config)#ephone-dn 3
Router(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 3.1, changed state to up
Router(config-ephone-dn)#number 3003
Router(config-ephone-dn)#exit
Router(config)#ephone-dn 4
Router(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 4.1, changed state to up
Router(config-ephone-dn)#number 3004
Router(config-ephone-dn)#exit
Router(config)#
Router(config)#ephone 1
Router(config-ephone)#button 1:1
Router(config-ephone)#
%IPPHONE-6-REGISTER: ephone-1 IP:10.1.1.7 Socket:2 DeviceType:Phone has registered.
Router(config-ephone)#exit
Router(config)#ephone 2
Router(config-ephone)#button 1:2
Router(config-ephone)#exit
%IPPHONE-6-REGISTER: ephone-2 IP:10.1.1.4 Socket:2 DeviceType:Phone has registered.
Router(config)#ephone 3
Router(config-ephone)#button 1:3
Router(config-ephone)#exit
%IPPHONE-6-REGISTER: ephone-3 IP:10.1.1.2 Socket:2 DeviceType:Phone has registered.
Router(config)#ephone 4
Router(config-ephone)#button 1:4
Router(config-ephone)#
%IPPHONE-6-REGISTER: ephone-4 IP:10.1.1.5 Socket:2 DeviceType:Phone has registered.
Router(config-ephone)#exit
Router(config)#
Router(config)#int s0/2/1
Router(config-if)#ip add 200.1.1.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/2/1, changed state to down
Router(config-if)#
Router(config-if)#exit
Router(config)#router eigrp 1
Router(config-router)#network 10.10.1.0
Router(config-router)#network 10.10.2.0
Router(config-router)#network 200.1.1.0
Router(config-router)#exit
Router(config)#
Switch 2 Configuration
Switch>
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 50
Switch(config-vlan)#name voice
Switch(config-vlan)#vlan 60
Switch(config-vlan)#name data
Switch(config-vlan)#exit
Switch#
Switch(config)#int range f0/1-4
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 60
Switch(config-if-range)#switchport voice vlan 50
Switch(config-if-range)#exit
Switch(config)#int f0/5
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#
Show ephone
The output off the show ephone command is given below
For the establishment of a wireless connection between the nearby warehouse and the remote site a Linksys router is used and it is connected with the main router of the office for communicating with each other. The list of the equipment’s are given below:
- Cisco 2811 series router x3
- Cisco 7960 IP phone x 9
- Linksys wireless router x 2
- PC x 9
- Cisco 2960 24 TT switch x 3
There are different factors that can affect the signal quality and strength of the signal because the RF signal are susceptible to the interference. For the wireless network the interference cannot be avoided but some countermeasures can be applied such as removal of the obstruction for increasing the range of the signal. The density of the obstruction material weakens the signals, there are some wireless technology such as 802.11 b/g which operates in the 2.4 Ghz frequency are used in many devices and thus can weaken the signal. For ensure that the efficiency of the wireless network is maintained the wireless access points should be installed in free space such that there are no obstruction near the access point. The efficiency of the wireless network can be improved with the application of the spread spectrum technology, where narrow band transmission is used (Rautaray and Agrawal 2015). The narrowband is also known as the shortest distance between two points and it uses less bandwidth than the spread spectrum. In the spread spectrum the direct hopping and frequency hopping is used. The narrowband signals are used in frequency hopping because it is predictable. It increases the range and minimize the influence of environmental factor and thus the direct sequence spectrum is developed where a redundant bit is sent with every bit of data for assuring the delivery of data and increasing the security of the data packets (Conti and Giordano 2014). The beacon frame management can also be applied for establishment of a wireless connection between the access point and the host. The access point sends the beacon frame and the client can detect the beacons automatically for the establishment of a connection with the access point.
Task C
Wireless security
For increasing the security of the wireless network it is important to apply encryption algorithm for authenticating the authorized user with the network and allow them to communicate with each other. There are different types of authentication mechanism such as open system authentication, shared key authentication, Ad Hoc mode, infrastructure mode, WEP, WPA, etc. the open system authentication is the default protocol for the 802.11 standard (Haleplidis et al. 2015). A simple authentication request is created which contains the SSID and the response of authentication. WEP can be used for improvement of the security and encryption of the data. In case of shared key authentication the client trying to authenticate with the access point, a challenge text is used for establishment of the authentication where the text is inputted by the client and for verification and on successful authentication the challenge text is decrypted at the access point end.
The Ad hoc mode can also be applied for the 802.11 standards where minimum two wireless stations are needed and the wireless access point may or may not be involved in the communication. There are some of the security techniques that are not available in the Ad hoc modes such as filtering of the Mac address and access control (Ahmed et al. 2015). In the infrastructure mode there are more than one number of wireless access point and it is suitable for larger wireless network and the complexity of this type of network is much when compared with the Ad hoc network. The WEP (wired equivalent privacy) protocol can be applied for maintaining the privacy in the wireless network by encrypting the data sent over the network (Shi, Bai and Yao 2017). There are some automated tool that can be used for cracking the WEP key and thus it is not applied without more secure methodology.
WPA (Wifi Protected Access) protocol was designed for fixing the security issues found on the WEP and it improves the assurance level and keep the data protected in the network with the application of thee TKIP algorithm. The second version of WPA works on the principle of IEEE 802.11i and it is a wireless security protocol where the client needs to use authentication using advanced encryption standards, stronger authentication control, key management and data integrity for the protection against the replay attacks (Kreutz et al. 2015). The WPA2 is susceptible to man in the middle attack and the internal users can inject malicious traffic for decrypting the private data. This can be mitigated with the application of the client isolation, where the clients connected to the wireless access point are not able to communicate with the other client connected in the same network.
Environmental issues and wireless standards
The TKIP algorithm was designed for increasing the security of the wireless network and it is the strongest algorithm. Some of the devices allows WPA to work with the AES algorithm and some devices uses the WPA 2 to work with the TKIP algorithm. The TKIP vulnerability can be uncovered, where the attacker can be able to decrypt the small data packets and inject arbitrary data in the network (Ferdoush and Li 2014). The strongest combination id the WPA2 with the AES and it should be used for securing the wireless network of Company ABC.
Conclusion
From the above report it can be concluded that with the development of the wireless network solution for organization Company ABC would be benefitted. The cost of data and voice transmission in the network can be decreased with the implementation of the VOIP network solution. The basic needs of the organization are fulfilled by the network solution and the configuration of the network are attached with the report with the evidence of screenshot for proper working of the network. The network is tested by pinging from different devices in the network and the wireless access points are password protected such that it cannot be used by unauthorized uses. The block diagram are used for designing the network and the issues that can arise with the network are analyzed for the increasing the security of the network. The wireless standards that can be applied in the network are analyzed and applied to ensure that the network is optimized. A discussion on the security standards and the combination of the algorithm that can be applied for securing the wireless network are also discussed such that the best strongest combination is applied during the configuration of the wireless access point installed in the company’s site.
Ahmed, E., Akhunzada, A., Whaiduzzaman, M., Gani, A., Ab Hamid, S.H. and Buyya, R., 2015. Network-centric performance analysis of runtime application migration in mobile cloud computing. Simulation Modelling Practice and Theory, 50, pp.42-56.
Al-Dulaimi, A., Al-Rubaye, S., Ni, Q. and Sousa, E., 2015. 5G communications race: Pursuit of more capacity triggers LTE in unlicensed band. IEEE vehicular technology magazine, 10(1), pp.43-51.
Bernardos, C.J., De La Oliva, A., Serrano, P., Banchs, A., Contreras, L.M., Jin, H. and Zúñiga, J.C., 2014. An architecture for software defined wireless networking. IEEE wireless communications, 21(3), pp.52-61.
Chen, M., Zhang, Y., Hu, L., Taleb, T. and Sheng, Z., 2015. Cloud-based wireless network: Virtualized, reconfigurable, smart wireless network to enable 5G technologies. Mobile Networks and Applications, 20(6), pp.704-712.
Conclusion
Conti, M. and Giordano, S., 2014. Mobile ad hoc networking: milestones, challenges, and new research directions. IEEE Communications Magazine, 52(1), pp.85-96.
Ferdoush, S. and Li, X., 2014. Wireless sensor network system design using Raspberry Pi and Arduino for environmental monitoring applications. Procedia Computer Science, 34, pp.103-110.
Grassi, G., Pesavento, D., Pau, G., Vuyyuru, R., Wakikawa, R. and Zhang, L., 2014, April. VANET via named data networking. In Computer Communications Workshops (INFOCOM WKSHPS), 2014 IEEE Conference on (pp. 410-415). IEEE.
Haleplidis, E., Pentikousis, K., Denazis, S., Salim, J.H., Meyer, D. and Koufopavlou, O., 2015. Software-defined networking (SDN): Layers and architecture terminology (No. RFC 7426).
Jan, M.A., Nanda, P., He, X. and Liu, R.P., 2014. PASCCC: Priority-based application-specific congestion control clustering protocol. Computer Networks, 74, pp.92-102.
Jarschel, M., Zinner, T., Hoßfeld, T., Tran-Gia, P. and Kellerer, W., 2014. Interfaces, attributes, and use cases: A compass for SDN. IEEE Communications Magazine, 52(6), pp.210-217.
Kizza, J.M., 2017. Guide to computer network security. Springer.
Kreutz, D., Ramos, F.M., Verissimo, P.E., Rothenberg, C.E., Azodolmolky, S. and Uhlig, S., 2015. Software-defined networking: A comprehensive survey. Proceedings of the IEEE, 103(1), pp.14-76.
Loo, J., Mauri, J.L. and Ortiz, J.H. eds., 2016. Mobile ad hoc networks: current status and future trends. CRC Press.
Mills, D.L., 2016. Computer network time synchronization: the network time protocol on earth and in space. CRC Press.
Rautaray, S.S. and Agrawal, A., 2015. Vision based hand gesture recognition for human computer interaction: a survey. Artificial Intelligence Review, 43(1), pp.1-54.
Sadiku, M.N., 2017. Simulation of Local Area Networks: 0. CRC Press.
Shabtai, A., Tenenboim-Chekina, L., Mimran, D., Rokach, L., Shapira, B. and Elovici, Y., 2014. Mobile malware detection through analysis of deviations in application network behavior. Computers & Security, 43, pp.1-18.
Shi, B., Bai, X. and Yao, C., 2017. An end-to-end trainable neural network for image-based sequence recognition and its application to scene text recognition. IEEE transactions on pattern analysis and machine intelligence, 39(11), pp.2298-2304.
Sicari, S., Rizzardi, A., Grieco, L.A. and Coen-Porisini, A., 2015. Security, privacy and trust in Internet of Things: The road ahead. Computer networks, 76, pp.146-164.
Smed, J. and Hakonen, H., 2017. Algorithms and networking for computer games. John Wiley & Sons.
Vasilakos, A.V., Li, Z., Simon, G. and You, W., 2015. Information centric network: Research challenges and opportunities. Journal of Network and Computer Applications, 52, pp.1-10.
Xia, W., Wen, Y., Foh, C.H., Niyato, D. and Xie, H., 2015. A survey on software-defined networking. IEEE Communications Surveys & Tutorials, 17(1), pp.27-51.
Yan, Q. and Yu, F.R., 2015. Distributed denial of service attacks in software-defined networking with cloud computing. IEEE Communications Magazine, 53(4), pp.52-59.
Yan, Q., Yu, F.R., Gong, Q. and Li, J., 2016. Software-defined networking (SDN) and distributed denial of service (DDoS) attacks in cloud computing environments: A survey, some research issues, and challenges. IEEE Communications Surveys & Tutorials, 18(1), pp.602-622.